"lift new package" page not working

I directly accessed https://tidelift.com/lifter/search/npm/internal-slot before I published the package - it now consistently fails to load, with the jellyfish. I accessed https://tidelift.com/lifter/search/npm/es-aggregate-error a second or two after publishing, and it worked immediately.

Perhaps something gets incorrectly cached in the former case? I’m still unable to apply to lift that package.

@ljharb thank you for letting us know! I’m also seeing Kingsley float across the screen so I’ll get the team to take a look. Can you please let me know the last time you were able to directly access https://tidelift.com/lifter/search/npm/internal-slot?

Never; i first accessed it before publishing the first version of the package.

@ljharb I believe the issue here is that since the package is so new we haven’t picked it up yet. I see how it could be super confusing since when you search by username, it does detect the package and lists it in the results, but if you click on it Kingsley appears. I’ll get more details on timing for new packages and also see about adding this manually.


I don’t believe that’s the problem, since in my original message i indicated that es-aggregate-error was available nearly instantly, as have other packages in the past.

Quite explicitly, this only happens when i access the new package page before it’s been published - there’s no delay if i wait til after.

@ljharb we’ve manually updated libraries.io so this package is now being detected and the information is also now being displayed properly is the dashboard search.

Thank you again for letting us know about this issue!

1 Like

Hey Brenna -

https://tidelift.com/lifter/search/npm/es-get-iterator (newly published) is also having the same issue; it’s listed properly on https://libraries.io/npm/es-get-iterator

guess i spoke too soon; it’s working now :slight_smile:

@ljharb please let us know if there are any other issues!

Hi Brenna :slight_smile: this is happening again with https://tidelift.com/lifter/search/npm/has-package-self-reference

(update: it’s since started working, and i applied to lift the new package)

1 Like

@ljharb perfect, thank you for the update!

It’s happened again: https://tidelift.com/lifter/search/npm/has-package-imports

@ljharb this is working for me, but we did make some site updates the other day that affected the package search for a short time. Can you please share a screenshot of what you’re seeing so I can share with the team?

It was the Kingsley jellyfish. I refreshed it this morning, and everything worked fine.

It does seem to consistently happen with newly published packages tho, even when I find the package via the “choose new packages” username search.